注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

.

.

 
 
 

日志

 
 

通达信芙蓉出水一周20%指标公式主图副图  

2018-03-27 18:14:01|  分类: 股票指标 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

DRAWGBK(CURRBARSCOUNT=1, RGB(110,600,108),RGB(88,120,100),0,'',0);DRAWGBK(CURRBARSCOUNT=1, RGB(110,600,108),RGB(88,120,100),0,'',0);AAA:=(3*C+H+L+O)/6;VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));DRAWKLINE(HIGH,OPEN,LOW,CLOSE);短线:VAR1,COLORWHITE;中线:VAR6,COLORYELLOW;下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;N1:=5;N2:=7;N3:=11;EM1:=EMA(C,N1),COLORWHITE;EM2:=EMA(C,N2),COLORRED;EM3:=EMA(C,N3),COLORGREEN;TJ:=BETWEEN(EM2,EM1,EM3);MA20:MA(C,20)LINETHICK3;IF(MA20>REF(MA20,1),MA20,DRAWNULL)COLORRED,LINETHICK3;立桩量:=FILTER(TJ=0,5);{芙蓉出水} MA200:=EMA(CLOSE,20); MA400:=EMA(CLOSE,40); MA600:=EMA(C,60); AA:=BARSLAST(MA400>MA600 AND (MA200=MA400 OR MA200>MA400)); BB:=REF(COUNT(C<MA600,AA)=AA,1); CC:=CROSS(C,MA600) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3; 芙蓉出水:=BB AND CC; STICKLINE(芙蓉出水,C,O,2,0),COLORYELLOW;DRAWTEXT(芙蓉出水,L-L*0.0005,'芙蓉出水'),COLORYELLOW;

 
{芙蓉出水副图}
MA200:=EMA(CLOSE,20);
MA400:=EMA(CLOSE,40);
MA600:=EMA(C,60);
AA:=BARSLAST(MA400>MA600 AND (MA200=MA400 OR MA200>MA400));
BB:=REF(COUNT(C<MA600,AA)=AA,1);
CC:=CROSS(C,MA600) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC;
STICKLINE(芙蓉出水,C,O,2,0),COLORYELLOW;
DRAWTEXT(芙蓉出水,L-L*0.0005,'芙蓉出水'),COLORYELLOW;

通达信芙蓉出水一周20%指标公式主图副图 - taonuonuo - taonuonuo的博客

对使用本公式出错说明和解决办法:

根据大家的留言,错误的都是“错误句 : DRAWGBK(CURRBARSCOUNT=1, RGB(110,600,108),RGB(88,120,100),0,1,0) ”,实际上公式的前面的句是对图画了个背景,去掉这两句结果是一样的,所以有问题或不喜欢有背景的股友可以使用以下公式源码:

AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
N1:=5;N2:=7;N3:=11;
EM1:=EMA(C,N1),COLORWHITE;
EM2:=EMA(C,N2),COLORRED;
EM3:=EMA(C,N3),COLORGREEN;
TJ:=BETWEEN(EM2,EM1,EM3);MA20:MA(C,20)LINETHICK3;
IF(MA20>REF(MA20,1),MA20,DRAWNULL)COLORRED,LINETHICK3;
立桩量:=FILTER(TJ=0,5);{芙蓉出水}
MA200:=EMA(CLOSE,20); 
MA400:=EMA(CLOSE,40); 
MA600:=EMA(C,60); 
AA:=BARSLAST(MA400>MA600 AND (MA200=MA400 OR MA200>MA400)); 
BB:=REF(COUNT(C<MA600,AA)=AA,1);
CC:=CROSS(C,MA600) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3; 
芙蓉出水:=BB AND CC; 
STICKLINE(芙蓉出水,C,O,2,0),COLORYELLOW;
DRAWTEXT(芙蓉出水,L-L*0.0005,'芙蓉出水'),COLORYELLOW;

{效果截图如下:}

通达信芙蓉出水一周20%指标公式主图副图 - taonuonuo - taonuonuo的博客

  评论这张
 
阅读(2)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018